The following hardware and software items are needed to run the ILLiad system effectively. They are not provided as part of the licensing of ILLiad or as part of the service contract with Atlas Systems.

These requirements ensure that ILLiad will perform well for you and have all the necessary features available to support functionality. While ILLiad may run in unsupported environments with older than minimum required software and hardware, we cannot guarantee operation.

Server Requirements

Icon

You can install Windows on a physical server or virtual server as long as it meets the hardware and software requirements.


The following hardware and software is compatible with the ILLiad server:

Processor
  • Intel Xeon 3Ghz or greater processor (recommended)
  • Intel Pentium 4 2Ghz or greater processor (minimum)
RAM

More RAM will substantially increase system performance

  • 8GB of RAM (recommended)
  • 4 GB of RAM (minimum)
Hard Drive
  • 72GB high speed hard drive (recommended)
  • 36GB hard drive (minimum)
Backup
  • Compatible backup device
Windows Server
  • Windows Server 2016 (Desktop Experience only)
  • Windows Server 2012 R2
  • Windows Server 2012
  • Windows Server 2008 R2 (minimum)
 Microsoft .NET
  • Microsoft .NET 4.5.1 Framework or higher full version
*SQL Server

SQL Express is not a supported database system

  • **SQL Server Native Client
  • Microsoft SQL Server 2017
  • Microsoft SQL Server 2016
  • Microsoft SQL Server 2014
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2008 R2
  • Microsoft SQL Server 2008 (minimum)
IIS
  • Internet Information Services 8.0
  • Internet Information Services 7.5 (minimum)

*ILLiad requires the SQL Server Database Engine, but does not use Analysis Services, Reporting Services, or Integration Serves. Mixed mode authentication is also required.

**The SQL Server Native client is installed as part of the client & server installation and is also part of the server update process, so no action is required. 

Client Requirements

The following hardware and software is compatible with the ILLiad client:

Processor
  • Intel Pentium 4 2Ghz (minimum)
RAM

More RAM will increase system performance.

  • 2GB of RAM (recommended)
  • 500MB of RAM (minimum)
Hard Drive
  • 18GB of free hard drive space (recommended)
  • 5GB of free hard drive space (minimum)
Display
  • 1280x1024 resolution or larger (recommended)
  • 1024x768 resolution (minimum)
Printer
  • Color ink jet printer (recommended)
  • Printer should be capable of handling removable labels
Windows
  • Windows 10
  • Windows 8.1
  • Windows 8
  • Windows 7
  • Windows Vista (minimum)
Microsoft .NET
  • Microsoft .NET 4.6.1 Framework or higher full version
Microsoft Office

32-bit or 64-bit can be used.

  • Microsoft Word 2016
  • Microsoft Word 2013
  • Microsoft Word 2010
  • Microsoft Word 2007 (minimum)
Internet
  • Microsoft Edge
  • Internet Explorer 11
  • Internet Explorer 10
  • Internet Explorer 9
  • Internet Explorer 8
  • Internet Explorer 7 (minimum)

Windows Version

If you are running 64-bit Windows, you will need to make a change to the .dll to support ILLiad. View your Windows version by going to Computer - Properties - System.

  1. Open the Internet Information Services (IIS) Manager on the server.
  2. Click on the server name, then click on Application Pools.
  3. Right click on the DefaultAppPool and click Advanced Settings.
  4. Change Enable 32-Bit Applications from False to True.